DIY Cam Position Sensor Easy Version - Page 5 - - Infiniti G35 & G37 Forum Discussion | rupromenergo.ru
Show Your Support Become A Premier Member

    > >
  • Reload this Page >
    • DIY Cam Position Sensor Easy Version


DIY Cam Position Sensor Easy Version

Thread Tools Rating: Thread Rating: 4 votes, 5.00 average.
Old 06-29-2011, 11:12 PM
Registered User
Thread Starter
Join Date: Feb 2011
location: Annapolis, Maryland
Posts: 123
Thanked 94 Times in 12 Posts
Quote:
Originally Posted by jwrape View Post
I have replaced my sensors BOTH twice now with parts from Rock Auto. Both times they tripped the CEL after about 5 miles. I am returning them for a refund.
I will buy Nissan parts next. BUT my question is how to properly test the sensor.

With a Ohm Meter I have had my original sensor show Ohm resistance on pins 2 and 3 together but nothing on Pin 1 and 2 or 3.

So my question is: What resistance should I get off pins 1-3 to check the sensor for correct operation?

I don't know what I'm looking for. They all read the same as above except the last one that showed resistance on only one pin and open on all the others.

Who know what to do to test?
I'm a little confused about what terminals you tested, but I can tell you how to do the test correctly. No matter what terminals you are testing, you are simply looking for any resistance reading. The resistance will vary according to many factors (temperature, connection quality, sensor wear, your meter etc.). All this test is really meant to check for is an open circuit within the sensor. If your meter is reading anything but open then your sensor is passing this test. This doesn't necessarily mean the sensor is positively good. If the sensor is reading open while you are correctly performing the test, then it is definitely bad. Sadly however, if the sensor is passing all the tests, it doesn't definitely mean it is good. If in doubt, I would just replace it depending on what codes and symptoms you are experiencing. Also make sure you get the polarity right when you are testing the terminals. Make sure the positive tester lead goes on the correct terminal and vise versa.

Test 1.)
Positive meter (red lead) lead goes on terminal #1. Place the negative lead (black lead) on terminal 2. Your meter should read a resistance value NOT open.

Test 2.)
Positive meter (red lead) lead goes on terminal #1. Place the negative lead (black lead) on terminal 3. Your meter should read a resistance value NOT open.

Test 3.)
Positive meter (red lead) lead goes on terminal #2. Place the negative lead (black lead) on terminal #3. Your meter should read a resistance value NOT open.

Like I said above, you are simply looking for a closed circuit, not a specific resistance reading. See the diagram below for the terminal numbers and more testing information.



Just out of curiosity, what codes do you currently have?

Last edited by Silver tiburon; 06-29-2011 at 11:21 PM.
Old 07-01-2011, 07:38 PM
Registered User
iTrader: (18)
Join Date: Apr 2010
location: Hot Springs, AR
Posts: 249
Thanked 6 Times in 4 Posts
Quote:
Originally Posted by Azhreal View Post
I've been unsuccessful in removing the bolt with all possible angles. My last shot is to find a 10mm wrench and go straight at it. What a pain this has been. I can almost get a 3 inch extension with 10mm attached flush on it but I can't get it to budge. The caution hot rod is right in line with the dang bolt.

I know you got yours done, but for the benefit of others who may read this thread in the future:

The best tool to remove the bolt with is a 10mm GearWrench. It's VERY worth the investment.
Old 08-05-2011, 10:21 AM
Registered User
Join Date: Oct 2006
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
You guys doing the driver side without removing anything.... you must have really small hands. I don't think there is anyway in hell I can get my hands back there and I'm not a big guy 5' 11 165. Passenger side is super easy.
Old 08-27-2011, 01:27 AM
Trickstyle's Avatar
Registered User
iTrader: (4)
Join Date: Jan 2011
location: Cherry Hill, NJ
Posts: 749
Thanked 27 Times in 21 Posts
I did my sensors today and its AMAZING!!! I cleaned my throttle body a few days ago(it was filthy) and i got minimal response gains. but after doing my sensors a few hours ago, its like a BRAND NEW engine!!! miles i restored god knows how much torque! i barely tap the gas and my baby GOES!!! My sensors have been messed up for so long tht i think my car forgot how to use its VDC lol when i hit the gas from a stop the tires screech. granted I need to re-learn my car(pre-cam sensor replacement my car was so doggy i had to push the pedal down A LOT to get a response from the car) but im hella happy w/ the results!!! do not delay! do it today!

Quote:
Originally Posted by Azhreal View Post
I have an 06 G35 Sedan and am trying to replace the passenger sensor and they have added a long metal rod that runs vertically behind the hose so that you cannot go directly at the bolt. Does anyone have any idea how to get to the bolt on an 06?! This is driving me insane.

you gotta set your ratchet aside for this one bro, i went to autozone and bought me a $8 10mm wrench, took a few seconds longer but I got it loose, then i undid the bolt by hand once it was loose enough. I also had my telescoping magnet(<[email protected]) on the bolt while i was undoing it incase the bolt were to fall.

Quote:
Originally Posted by jin22gt View Post
......Good luck on trying to remove the green harness thats connected to the sensor. Had alot of problem trying to remove the harness.
i got this pic Evan78, but i took a pliers and squeezed the clip inward(the arrows on the picture) then the sensor came out with ease. DO NOT pull on the wires, my buddy did his 350z at the same time and he pulled a wire out of the harness :/ we soldered it back it but it took a while.




Reference: http://rupromenergo.ru/forums/g-spot/...hts-all-4.html Post #55

Error codes:
P0340 = bad passenger side cam position sensor (right hand side)
P0345 = bad driver side cam position sensor (left hand side)
The Following User Says Thank You to Trickstyle For This Useful Post:
Davidle92 (09-11-2013)
Old 09-07-2011, 03:51 PM
Registered User
iTrader: (4)
Join Date: Jul 2008
location: in my G
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Is this code seen here referring to the same sensors in this thread? I know this is a broad question but what might have cause the sensor to suddenly fail? thanks!
Attached Thumbnails
DIY Cam Position Sensor Easy Version-img_2616.jpg
Old 09-07-2011, 03:54 PM
Registered User
iTrader: (18)
Join Date: Apr 2010
location: Hot Springs, AR
Posts: 249
Thanked 6 Times in 4 Posts
No, I think that code is referring to an O2 sensor. However, if your cam sensor(s) haven't been changed, then you should probably begin making plans to change them anyway.
Old 09-07-2011, 04:30 PM
Registered User
iTrader: (4)
Join Date: Jul 2008
location: in my G
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by vinco View Post
No, I think that code is referring to an O2 sensor. However, if your cam sensor(s) haven't been changed, then you should probably begin making plans to change them anyway.
So these are the exact same sensors located by the cats/test pipes? I have berk HFCs now. Before I had megan TPs which caused CEL but I used non foulers and reset the ECU so all was good. Now i have SES light after putting on HFCs WTF:bang head: was just wondering what could cause this. at the moment i have just a bit of exhaust leak (JIC y-pipe meets mid-pipe) but this is after the O2 sensor...should it cause that code P2A03 or is that from something else? throttle response is horrible at high RPM 60+mph, i can feel the difference. any ideas
Old 09-07-2011, 04:36 PM
JaE35's Avatar
Sedan >
iTrader: (37)
Join Date: Jul 2010
location: DFW, TX
Posts: 8,281
Thanked 794 Times in 670 Posts
Man the o2 sensors really do hate to be touched...pretty sure you need to replace one, common occurrence lately.
Old 09-08-2011, 09:21 PM
Registered User
iTrader: (4)
Join Date: Jul 2008
location: in my G
Posts: 93
Thanks: 0
Thanked 0 Times in 0 Posts
From what i heard, these sensors are before the cats. BANK 2 SENSOR 1 & BANK 1 SENSOR 1. Am I correct? does anyone have a clue or can chime in on this?
Old 09-08-2011, 11:41 PM
Registered User
iTrader: (18)
Join Date: Apr 2010
location: Hot Springs, AR
Posts: 249
Thanked 6 Times in 4 Posts
Sensor 1 on either bank is the one that's closest to the engine.
Old 09-11-2011, 12:19 AM
Trickstyle's Avatar
Registered User
iTrader: (4)
Join Date: Jan 2011
location: Cherry Hill, NJ
Posts: 749
Thanked 27 Times in 21 Posts
Quote:
Originally Posted by pvdg35 View Post
From what i heard, these sensors are before the cats. BANK 2 SENSOR 1 & BANK 1 SENSOR 1. Am I correct? does anyone have a clue or can chime in on this?
If im not mistaken... bank 1, sensor 1 and bank 2, sensor 1 are referring to the camshaft postition sensors, which are on the back of the head of your engine.

The O2 sensor is the one by your cats, idk if its before or after, but i hear its EXTREMELY fragile, and you will most likely break it when trying to remove it

hope tht helps
Old 09-11-2011, 10:04 PM
Registered User
iTrader: (3)
Join Date: Sep 2008
location: NYC
Posts: 170
Thanked 8 Times in 8 Posts
I'm getting this code when I did a scan reading.

P1084 (Bank 2). Please help me figure which sensor needs to be changed. The drivers side or the passenger side? Thanks.
Old 09-12-2011, 08:20 AM
Trickstyle's Avatar
Registered User
iTrader: (4)
Join Date: Jan 2011
location: Cherry Hill, NJ
Posts: 749
Thanked 27 Times in 21 Posts
Quote:
Originally Posted by ErikNYC View Post
I'm getting this code when I did a scan reading.

P1084 (Bank 2). Please help me figure which sensor needs to be changed. The drivers side or the passenger side? Thanks.
p1084 in the 07 service manual is the EVT control position sensor. Not sure what year your car is though. If it's an 03-05 non-revup it would mean something else b/c they don't have EVT and could also be different for an 06 even if it is a revup with EVT.

taken from post 15
Old 09-12-2011, 04:28 PM
Registered User
iTrader: (3)
Join Date: Sep 2008
location: NYC
Posts: 170
Thanked 8 Times in 8 Posts
Quote:
Originally Posted by Trickstyle View Post
p1084 in the 07 service manual is the EVT control position sensor. Not sure what year your car is though. If it's an 03-05 non-revup it would mean something else b/c they don't have EVT and could also be different for an 06 even if it is a revup with EVT.

taken from post 15
Thank you very much. i do have a '05 rev-up G35c. As of now, i'm leaning towards it meaning the exhaust camshaft position sensor is bad.


Bank number two is the drives side right? This thread had confused me a little bit. Thanks again.
Old 09-17-2011, 04:13 PM
Registered User
Join Date: May 2008
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
I recently noticed my Service Engine Soon light turned on. Then yesterday, while driving home, my car suddenly stopped and a whole bunch of lights turned on the dash and I couldn't go faster than 5mph. I put the car in park, closed the engine and tried to restart it but it didn't want to. Finally I got it started, and got home. I hooked it up to my tester, and got the P0345 error code, which has something to do with this thread and the camshaft. Now, I am willing to order the parts online and doing it myself and I was wondering where I can get the parts for this error code (the exact link to the parts so all I can do is pay for them, as I don't know from where I should order them and which exact part I need). If anyone can help me that would be greatly appreciated.
I have read that it could be the driver's or passenger cam shaft sensor that could be faulty, and I would like to replace both so I do not need to worry about this issue again.

Thanks for your time

Related Topics
Thread Thread Starter Forum Replies Last Post
P1239 Faulty Electric Throttle Control Actuator Freeman186 Engine, Drivetrain & Forced-Induction 0 09-05-2015 12:28 AM
Not sure what's wrong. Doesn't run... n2fooz Engine, Drivetrain & Forced-Induction 0 09-04-2015 08:46 PM
Fixed inifiniti's brake design flaw with Nissan akebono big brakes Machine Head G35 Sedan V35 2003-06 19 09-04-2015 08:22 PM
Oil leaks from multiple locations UT G35 General Tech Questions 6 09-03-2015 04:58 PM


Tags
2003, bank, cam, camshaft, connector, coupe, dyi, g35, infiniti, location, position, removing, replace, sensor, test
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:41 PM.


Copyright ©2002 - 2017, rupromenergo.ru All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:

Related pages


replacing clutch master cylinderinfiniti g35 coupe for sale los angeles2005 infiniti g35 navigation systemrohanna rc10infinity kappa ampare nankang tires any goodclutch throw out bearing replacement costca dmv change of title350z exedy clutchdamper coiloversxxx 18xxxxtiptronics transmissionstagea owners clubautocross trailerwindow tint law in vavq35hr itb2005 altima seraudiowerks san joselexus gs430 foruminfiniti g35 coupe trunkg35 staggered wheelspaste vs liquid waxg35 coupe hoodvc 22356 b california finebrake caliper temperaturepurolator pl14610 pureone oil filterp0420 and p0430po301 cylinder 1 misfirecentric posi quiet ceramic brake padsvalve cover leaking oilpainting carbon fiberremoving emblemswater sloshing sound in car2007 nissan altima transmission fluid changedebadging a truck6000k colordifference coupe sedanac belt tensionerstoptech slotted rotorslost lug nut keyreprogram transmission control moduleinstyleshoes.com legittakakairaserpentine belt drive beltg35 sedan fog lightslm20 wheelsvelocity stack intakeinfiniti m45 on 22sknock off bbs rimsflywheel torque settingsbrembo caliper paintmorrey infiniti coquitlamplastic paint for rimsg37 reviewgarax d4sk&n recharge kit2005 acura tl bolt patternlojack stickeroil light comes on when brakingg35 coupe tiresinfiniti airbag recalllanzar speakersf1 paddle shiftpontiac g8 gt reliabilitycontinental dws extremecoilovers g35g37 coupe wheelscharles barker infinitijbt brakeswindshield wiper fluid leaking reservoirfhp8000btrubbing noise while drivingtape player aux walmartkicker l7 15 enclosurerobert thibert wheelsaam test pipesg35 rear wheel drive2003 g35