Service Engine Soon (SES) light and Computer Reset - - Infiniti G35 & G37 Forum Discussion | rupromenergo.ru
Show Your Support Become A Premier Member

    > >
  • Reload this Page >
    • Service Engine Soon (SES) light and Computer Reset


Service Engine Soon (SES) light and Computer Reset

Thread Tools Rate Thread
Old 07-28-2009, 12:40 PM
Registered User
Thread Starter
iTrader: (4)
Join Date: May 2005
Posts: 697
Thanks: 0
Thanked 1 Time in 1 Post
Service Engine Soon (SES) light and Computer Reset

Last night I was driving home and my 05 coupe with 65K just turns off going 70mph. The Service Engine Soon light (not the Check Engine light) and the VCD light went on. So I pull over car is still off, I turn key to off position and all lights go off, then I turn car on and it fires up fine, all lights are off except the Service Engine Soon light. I drove car home, felt fine, and this morning going to work also felt fine but the SES light still on. If I take to dealership im sure will charge aleast 100 just to look at it...should I just reset computer and see if comes back on?

Saw this on another post:

Basic ECU Reset

Operations Procedures:

1. Confirm that accelerator pedal is fully released, turn ignition switch “ON” (NOT start) and wait 3 seconds.
2. Repeat the following steps (2a and 2b) procedures quickly five times within 5 seconds.
2a. Fully depress the accelerator pedal (HARD).
2b. Fully release the accelerator pedal.
3. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 10 seconds until the CEL starts blinking.
4. Fully release the accelerator pedal (while the CEL is still blinking)
5. Wait about 10 seconds.
6. Fully depress the accelerator pedal and keep it for more than 10 seconds.
7. Fully release the accelerator pedal (The CEL light will continue to blink).
8. Turn ignition switch to “OFF” position and now you can start the car. The CEL light should be gone. If the CEL light continues to remain ON, repeat the above steps. Remember, timing is EXTREMELY critical to resetting the ECU. You may even need someone's help to do this correctly.


Is this the right way to reset the computer? Any advice?? Thanks!
The Following User Says Thank You to mario24601 For This Useful Post:
djvillin602 (07-20-2016)
Old 07-28-2009, 12:46 PM
Registered User
iTrader: (33)
Join Date: Nov 2007
location: Burlingame/Berkeley, CA
Posts: 6,081
Thanked 1 Time in 1 Post
take it to an autozone, they should pull the codes for free and you can see if it's anything worth worrying about. is ur car stock?
Old 07-28-2009, 12:48 PM
Registered User
Thread Starter
iTrader: (4)
Join Date: May 2005
Posts: 697
Thanks: 0
Thanked 1 Time in 1 Post
Stock for most part, put Z tube about a year ago and Stillen exhaust about 2 years ago.
Old 07-28-2009, 02:23 PM
aRT13's Avatar
Registered User
iTrader: (8)
Join Date: Apr 2005
location: L.A./626
Posts: 1,091
Thanks: 0
Thanked 1 Time in 1 Post
I just got this light too. Service Engine Soon...on my navi it states "Malfunction, possible emission control problem"
Old 07-28-2009, 06:12 PM
Registered User
Thread Starter
iTrader: (4)
Join Date: May 2005
Posts: 697
Thanks: 0
Thanked 1 Time in 1 Post
Been reading more past threads...sounds like should do a reset and see if it comes back. Can someone confirm that the notes I posted in the first post is the correct way to do a reset...I remember in my old car all I had to do was disconnect the battery for a few minutes and then reconnect...anyone actually done a reset? How?
Old 07-28-2009, 10:55 PM
g35dalf's Avatar
Registered User
Join Date: Apr 2005
Posts: 243
Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by mario24601 View Post
Last night I was driving home and my 05 coupe with 65K just turns off going 70mph. The Service Engine Soon light (not the Check Engine light) and the VCD light went on. So I pull over car is still off, I turn key to off position and all lights go off, then I turn car on and it fires up fine, all lights are off except the Service Engine Soon light. I drove car home, felt fine, and this morning going to work also felt fine but the SES light still on. If I take to dealership im sure will charge aleast 100 just to look at it...should I just reset computer and see if comes back on?

Saw this on another post:

Basic ECU Reset

Operations Procedures:

1. Confirm that accelerator pedal is fully released, turn ignition switch “ON” (NOT start) and wait 3 seconds.
2. Repeat the following steps (2a and 2b) procedures quickly five times within 5 seconds.
2a. Fully depress the accelerator pedal (HARD).
2b. Fully release the accelerator pedal.
3. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 10 seconds until the CEL starts blinking.
4. Fully release the accelerator pedal (while the CEL is still blinking)
5. Wait about 10 seconds.
6. Fully depress the accelerator pedal and keep it for more than 10 seconds.
7. Fully release the accelerator pedal (The CEL light will continue to blink).
8. Turn ignition switch to “OFF” position and now you can start the car. The CEL light should be gone. If the CEL light continues to remain ON, repeat the above steps. Remember, timing is EXTREMELY critical to resetting the ECU. You may even need someone's help to do this correctly.


Is this the right way to reset the computer? Any advice?? Thanks!

Yes, this is the correct procedure. I've done it several times.
Old 07-29-2009, 04:28 PM
aRT13's Avatar
Registered User
iTrader: (8)
Join Date: Apr 2005
location: L.A./626
Posts: 1,091
Thanks: 0
Thanked 1 Time in 1 Post
Yeah, this is the correct way. I just did it now and my SES light has not come back.
Old 11-18-2016, 05:37 PM
Registered User
Join Date: Nov 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
I'm having an issue with my 05 G35 coupe. A couple of days ago I was driving and I literally could feel my car lose all the power. My service engine soon light came on and my car (automatic) wouldn't shift gears; my RPMs were increasing as my speed did but wouldn't shift. I took it to a mechanic and he said it was putting out codes for my "Front Brake Pressure Switch and my Transmission Pressure Switch". I took it to a Transmission specialtist and he said it's not my tranny, its something to do with the computer. I did the full Factory (SES) light and computer reset. The light turned off and i was back to driving normal for about 3 minutes, but then kicked back on. I'm not sure what else to do.
Old 11-18-2016, 05:43 PM
Urbanengineer's Avatar
Registered User
iTrader: (2)
Join Date: Jun 2013
location: Pig Town, OHIO
Posts: 8,129
Thanked 642 Times in 606 Posts
Check the battery voltage at idle and get it load tested first to make sure the battery isn't dying.

From there, check all codes.
Old 11-18-2016, 05:59 PM
Registered User
Join Date: Nov 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Urbanengineer View Post
Check the battery voltage at idle and get it load tested first to make sure the battery isn't dying.

From there, check all codes.
I just checked the battery voltage and im sitting at about 22-23 Volts.....
Old 11-18-2016, 10:22 PM
Registered User
Join Date: Nov 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by drewdrewww View Post
i just checked the battery voltage and im sitting at about 22-23 volts.....
12-13v **
Old 01-15-2018, 09:24 PM
Registered User
Join Date: Jan 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
You forgot 2 step

Quote:
Originally Posted by mario24601 View Post
Last night I was driving home and my 05 coupe with 65K just turns off going 70mph. The Service Engine Soon light (not the Check Engine light) and the VCD light went on. So I pull over car is still off, I turn key to off position and all lights go off, then I turn car on and it fires up fine, all lights are off except the Service Engine Soon light. I drove car home, felt fine, and this morning going to work also felt fine but the SES light still on. If I take to dealership im sure will charge aleast 100 just to look ait...should I just reset computer and see if comes back on?

Saw this on another post:

Basic ECU Reset

Operations Procedures:

1. Confirm that accelerator pedal is fully released, turn ignition switch “ON” (NOT start) and wait 3 seconds.
2. Repeat the following steps (2a and 2b) procedures quickly five times within 5 seconds.
2a. Fully depress the accelerator pedal (HARD).
2b. Fully release the accelerator pedal.
3. Wait 7 seconds, fully depress the accelerator pedal and keep it for approx. 10 seconds until the CEL starts blinking.
4. Fully release the accelerator pedal (while the CEL is still blinking)
5. Wait about 10 seconds.
6. Fully depress the accelerator pedal and keep it for more than 10 seconds.
7. Fully release the accelerator pedal (The CEL light will continue to blink).
8. Turn ignition switch to “OFF” position and now you can start the car. The CEL light should be gone. If the CEL light continues to remain ON, repeat the above steps. Remember, timing is EXTREMELY critical to resetting the ECU. You may even need someone's help to do this correctly.


Is this the right way to reset the computer? Any advice?? Thanks!
After step 7 you have to wait 10 seconds then depress the pedal for 10 seconds

Related Topics
Thread Thread Starter Forum Replies Last Post
New to FX. Having issues. SiMpLyMoDiFiEd The FX-Spot 1 08-09-2015 08:22 PM
(Slip light VDC light Off) keeps coming on Mry General Tech Questions 1 07-21-2015 03:03 PM
Getting P1128 code - Throttle Control Motor Circuit Short Hasanbaloch Engine, Drivetrain & Forced-Induction 5 07-19-2015 03:13 PM
Service Engine light question igking Engine, Drivetrain & Forced-Induction 3 07-19-2015 02:12 AM
Any G35 Veteran want to help me out in the Cupertino / San Jose area to check my car? mjfenix G35 Coupe V35 2003 - 07 0 07-17-2015 03:07 PM


Tags
05, 2008, check, computer, driver, engine, g35, g35x, infiniti, light, maintenance, reset, schedule, service, ses, turn
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:31 AM.


Copyright ©2002 - 2017, rupromenergo.ru All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:

Related pages


bendix brakes reviewbridgestone potenza re50als1 com forumsavh p3300bt pioneercar overheating while drivingcanadian bride seatsadjustable tienvalvoline full synthetic 5w30firestone eden prairie mndarkest tintwheel cupping2004 infiniti g35 performance chipg35 z tubek&n filter without oilhow to rotate asymmetrical tiresvortec v32002 volvo s60 reliabilityfuel filler hoseinfiniti northern vamenzerna si 1500ktc hr200evap canister vent solenoid valveforgestar f10wagjag red rocketsradio ipod adaptersubframe bushinghalolightinghow much does a turbo rebuild costhow to repair cracked dash paddura lube fuel system cleaner reviewg35 single turbodouble din android tabletbc racing coilover2006 m35 specsadapter for subwoofer to stock radioclutch pedal stuck to floorhks t51how many coil packs are in a carinfiniti qx56 batteryintegra valve adjustmentapple auto glass halifaxrunning colder spark plugswindow tinting guelphbay area powder coatingengine is knockingheadlight hazetools for spark plug changeengine plenumcar shakes when stoppedjaxed craigslistg35 throttle body spacerrb26 swap for salebrand new 2jz engine350z aftermarket rimsfront bumper license plate hole plugscherokee fartingflowmaster 80 series mufflertein s tech springs90 degree valve stem335i maintenance costsswaintech white lightningmaaco full paint job pricejh9floor jack adapter pinch weldcar rubbing compoundinfiniti lislehydrolock cold air intakeusafilterstorenissan skyline emblemtrue dual straight pipestsw donnington350z nismo rims for salebosal mufflerscar wont go faster than 30mphdallas rim repair350z bolt ons