All 4 of my o2 sensors are BAD?? - - Infiniti G35 & G37 Forum Discussion | rupromenergo.ru
Show Your Support Become A Premier Member

    > >
  • Reload this Page >
    • All 4 of my o2 sensors are BAD??


All 4 of my o2 sensors are BAD??

Thread Tools Rate Thread
Old 04-01-2010, 01:38 AM
Registered User
Thread Starter
Join Date: Jan 2008
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
All 4 of my o2 sensors are BAD??

I have a 2003 G35 coupe thats auto. It is all stock, no mods whatsoever with 78,5xx mlies. A couple of weeks ago my service engine soon light came on and I had my buddy check the codes. Turns out that all four o2 sensors are bad. My question is, is it possible for another sensor, bad ground, bad cat, or anything else make the o2 sensors go bad or make the computer think the o2 sensors are bad? We have cleared the codes and they have come back. Has anyone had the same problem, any help would be great.
Old 04-01-2010, 01:46 PM
Registered User
Thread Starter
Join Date: Jan 2008
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
bump for information
Old 04-01-2010, 06:39 PM
Dr. Ephil's Avatar
Registered User
iTrader: (1)
Join Date: Dec 2007
location: New Westminster,BC,Canada
Posts: 310
Thanked 15 Times in 13 Posts
What kind of OBD2 reader did your friend use to pull the codes? Most readers pull generic codes and give you a general idea of what's wrong. The reader at the stealership pulls up a lot more specific info. Other places probably have the stealership reader and charge less for diagnostics.

The better OBD2 readers you can buy allow real time data-logging so you can trace exactly what conditions caused the CEL to come on.
Old 04-01-2010, 09:14 PM
Registered User
iTrader: (31)
Join Date: Aug 2008
location: 714
Posts: 3,020
Thanked 58 Times in 31 Posts
x2 ^ Sounds like the OBD is just pulling a generic code. Pretty crazy that all four magically go. Try another reader, if not that sucks.
Old 04-02-2010, 05:01 PM
Registered User
iTrader: (9)
Join Date: Nov 2008
location: Omaha, NE
Posts: 353
Thanks: 0
Thanked 9 Times in 9 Posts
I have 3 o2 sensors that went bad all at once. I replaced the 2 in the cats with $60 bosch universal o2 sensors and I was still getting the same code (I have cypher). Took it the dealership and they said not to use the universal o2 sensors as they have been having problems with them on our cars. I priced them out and a new set (4) would cost you around $500. I have yet to replace mine, but I don't drive it anywhere.

hope this helps, and good luck
Old 04-03-2010, 03:37 AM
Registered User
Join Date: Nov 2009
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Try Seafoam first, might clean things up enough to not need to replace anything...
Old 04-03-2010, 05:02 AM
Registered User
iTrader: (2)
Join Date: Dec 2009
location: Northern VA
Posts: 374
Thanked 4 Times in 3 Posts
It's a bull****tttt
Old 04-03-2010, 02:42 PM
Registered User
iTrader: (31)
Join Date: Aug 2008
location: 714
Posts: 3,020
Thanked 58 Times in 31 Posts
Quote:
Originally Posted by SkyWay View Post
I have 3 o2 sensors that went bad all at once. I replaced the 2 in the cats with $60 bosch universal o2 sensors and I was still getting the same code (I have cypher). Took it the dealership and they said not to use the universal o2 sensors as they have been having problems with them on our cars. I priced them out and a new set (4) would cost you around $500. I have yet to replace mine, but I don't drive it anywhere.

hope this helps, and good luck
thats weird. Currently I have 2 30$ universal ones that work fine.....
Old 04-05-2010, 02:58 PM
Registered User
Join Date: Feb 2010
Posts: 125
Thanks: 0
Thanked 0 Times in 0 Posts
What code did you get? If its for both banks running lean, you may want to check for a vacuum leak somewhere.
Old 04-06-2010, 08:46 PM
Registered User
iTrader: (1)
Join Date: Sep 2008
Posts: 1,598
Thanked 15 Times in 14 Posts
best bet in this case is to take it to a shop

it may just be one that is bad or it may not even been the O2 sensors, it maybe something before them.
Old 04-06-2010, 08:54 PM
Registered User
iTrader: (8)
Join Date: Jan 2010
location: san diego, ca
Posts: 177
Thanks: 0
Thanked 0 Times in 0 Posts
i dont know if this helps out, but on my 4runner, my 02 sensors were showing up, yesterday my battery died and i replaced it, with the new battery the o2 sensor light doesnt show up anymore, i dont know if its resolved, but it was the first time i changed my 4runner battery since it was purchased in 03
Old 04-08-2010, 12:31 AM
Registered User
Thread Starter
Join Date: Jan 2008
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Wow thank you all for your input. The scanner that was used is a Snap-on model, I do not recall the exact model. The scanner did read not one o2 sensor but all four... yes all four codes for each o2 sensor. I will check for vacuum leaks tomorrow. Does anyone have any other ideas?
Old 04-09-2010, 09:06 PM
Dr. Ephil's Avatar
Registered User
iTrader: (1)
Join Date: Dec 2007
location: New Westminster,BC,Canada
Posts: 310
Thanked 15 Times in 13 Posts
What codes did the scanner pull? Copy them down and post them otherwise we can only give our best guesses.
Old 04-15-2010, 01:30 PM
speedjunkie_G35's Avatar
Registered User
iTrader: (3)
Join Date: Jun 2008
location: P'cola, FL
Posts: 140
Thanked 1 Time in 1 Post
I am currently having a similar issue. I got a P1031 and a P1148. I thought it might be the MAF but after cleaning that I still have the same codes pop back up.

AND DON'T USE SEAFOAM, THATS WHY I AM IN MY CURRENT SITUATION.


I was alway under the impression that you need to replace all O2 sensors when one goes out because 90% of the time the other one will go out soon after??? But I have never dealt with 4 O2 sensor.
Old 04-22-2010, 01:16 PM
Registered User
Join Date: Mar 2010
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mine is showing the exact same thing.
all 4 both banks in alarm.

I hope I dont have to replace all 4 sensors that would really suck.

supposed to take it back to the dealership where I bought it to have it looked at for the door locks not working as well.
they said they would look at the o2's and the SES for me as I just got the car less than 3 weeks and the SES popped on the drive home.

Related Topics
Thread Thread Starter Forum Replies Last Post
Transfercase removal / AWD light is ON / C1204 C1210 codes Danielek G35 Sedan V35 2003-06 3 10-08-2015 11:36 AM
Not sure what's wrong. Doesn't run... n2fooz Engine, Drivetrain & Forced-Induction 0 09-04-2015 08:46 PM
Oil leaks from multiple locations UT G35 General Tech Questions 6 09-03-2015 04:58 PM


Tags
02, 1820inch, bad, codes, coupe, g35, rupromenergo.ru, long, makes, o2, once, repeatedly, replace, sensor, sensors
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:51 AM.


Copyright ©2002 - 2017, rupromenergo.ru All Rights Reserved. We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:

Related pages


vq35detwill autozone check codesg35 coupe tiresusafilterstorereplacement battery for infiniti g37 key fobautotoyzflush power steering fluid costjlw7 13.5offset calculator wheelsvq35de performancesuspension strut replacement costhow much does it cost to fix a sway barce28 volkalpine iva d105 pricexxr 962 goldcarb legalsingle din flip down screenrohana rc10 for salerear clunking noise over bumpshow to rebuild a rack and pinionpermaseal waxgas gage fuseorion 4000 watt amp2006 honda civic battery lightpioneer avh-4000nexhow much are vossen wheelschevron with techronmichelin pilot alpin winter tireshow to remove door dingscar does not acceleratep0340 camshaft position sensor a bank 1single turbo for 350zcamshaft position cmp sensorwindow tint laws castanced tireshow to fix petrol gauge2871 turbogtr canada forumturbo vs supercharger pros and consfk-452sevas wheels350z exedy clutchm24 garrett2006 infiniti g35 coupe recallscostco 10x20 carport350z bumper clipshow much does it cost to fix a sway barcheap coiloverbithlo drag strip2 ohm 6x9 speakersnissan murano backup camera not workingvalvoline 5w30 full synthetic2007 infiniti g35x specsinfiniti i35 headlightsstance sc6bay area toll violationasa wheels bbsamp and sub installationperry infiniti of escondidopiaa super rozza wheelshypertech max energy tuneracura tl high mileage335i vs s5p0420 p0430falken fk 452 reviewslicense plate fastenerhow to build a cold air intake350z top secret diffuserinvisicord radar detectoryokohama avid tires reviewturbonetics gtk 500oracle hid kitskoni shocks review350z amuse front bumpermanifold spacerg35 nitrous kitg35 turbonetics kit