Engine Stall and Limp mode problems, I NEED YOUR HELP!! - - Infiniti G35 & G37 Forum Discussion | rupromenergo.ru
Show Your Support Become A Premier Member

    > >
  • Reload this Page >
    • Engine Stall and Limp mode problems, I NEED YOUR HELP!!

Engine Stall and Limp mode problems, I NEED YOUR HELP!!

Thread Tools Rate Thread
Old 02-21-2013, 10:38 PM
Registered User
Thread Starter
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Engine Stall and Limp mode problems, I NEED YOUR HELP!!

Hello, my name is Sean and I live near Detroit Michigan. In my town there is barely any G or Z cars so it is really hard get help when I get any problem on the car. If you are in Michigan and know any shop who knows G35 well, please let me know. Also I donít have much knowledge about carís mechanism so please be mindful on my explanation.

I have 2003 G35 coupe 6sp and recently I am suffering a mysterious and stressful problem with my G from last 3 months. Itís been 4 years since I bought a used one and I took a good care of it ever since. It currently has 125,000 miles and I drove it from 80,000 miles.

Before I begin my story(very long), I would like to summarize the problems I currently have:
-Engine stalls on start up. I can keep it going by pressing a gas pedal, but the idle is unstable and can immediately get into a ďLimp ModeĒ (with VDC,SLIP, Engine Service Soon Light on) with 1000rpm limit, 10 MPH speed limit

-Also I get 7 different OBD code when I scan

-Possible electrical problem but have a no ideas. No mechanics so far found out the exact problems. Replaced TB and MAF sensor did not work so far. Also I still get a MAF sensor code even after I replaced it.

To begin with, I want to mention my previous repair history which I think might affect to the current situation.

On last November, my carís audio and climate control starts to disable. Sometimes it works, but sometimes the entire control is lost after few sec~min of vehicle start up. When controls are lost, I get a full blast of the air from the vent (although my climate system was off, it automatically starts) with the last preset temperature I had. But I still had audio sound and control from the steering wheel. Just no display and control from the center stack.

Other function was normal except the audio and climate control. Navi worked fine as well. I kept drove it.

On last December 27, after 100 miles of driving (I was in Canada), the car suddenly got into a limp mode when I was making a right turn. It was pretty cold day and I went for sking so the temperature was fair low (10 F or something) I had a climate and audio control alive on the center stack that day (some days it worked through entire driving, sometimes it just dead on the start-up). I stopped a car and turned it on again, the Limp mode was still engaged. I did it few times and finally the limp mode was gone, but the Engine service soon light came on and stayed.

Early January, I replaced the audio unit purchased from Infiniti dealership. It was installed by a local shop that specializes in Nissan and Infiniti (In Toronto, Canada) I also told them that I went to a limp mode once and they did OBD scan and told me the code is from the knock sensor. They just told me to drive more and see if it comes on again. They erased the code. They also noticed that I have a ticking sound from the engine and told me it might cause knock sensor to pop up the SES light.
In mid-January, One day the limp mode is on again after I exit from the highway and drive on the local road (About 30Mph). I pulled the car and started up again, the limp mode is gone and SES light is on again. Went to the local shop and pulled a scan code. They told me I have a numbers of code, just erased the code and did not do anything.

About a week later----------------------serious stuff begins
One day, I drove car for 30 miles and decided to change my air filter and put some addictive to my engine oil. I Went to Autozone and got a new 3Ē cone filter for my Injen Short Ram Intake. I changed filter and put an addictive. Car started up fine and I drove for another 30 miles on highway. After few hours, I started car and it went stall right away with the limp mode engaged. I tried to start up few times with pressing pedal, and it started but limp mode was on. I turned off and on but the limp mode is still on. The day was very cold (0 F) so I keep the car running about 30 min with the limp mode on. Suddenly some weird noise is heard so I went out, the car start to throw out coolant from the reservoir. Coolant temp was normal and there was no steam when I open the hood. It didnít throw out a lot, but some coolants were spilled. I got scared and called a tow truck to my local shop that I went a week before.

They tried to start up the car normally. So cleaned throttle body and MAF sensor and so on, but did not solve the startup problem. ECU reset is tried but nothing happened (Limp mode still on) They said the fuel system is fine so they said I might have a bad TB or MAF. So I replaced to brand new OEM TB and nothing got better. So I replaced MAF Sensor, but still the same. The car is in a limp mode all the time so they told me they could not perform re learning stuff on TB and MAF sensor. The mechanic said he checked everything (wire,fuse,relay etc) he could possibly do. I also changed to new engine oil (Mobile 1 full synth extended performance 5W-30)

So I ended up with spending $700 for new TB and MAF sensor and the car stayed a whole week at the shop. Nothing got better so I towed it to the Infiniti dealership.

Dealership did a diagnostic and pulled a scan code. However, they told me that they need more time to look at the wires and stuff to find out the exact problem. They told me itís a $600 to just find out the problem so I said no thanks. But I got OBD codes and mechanicís opinion on the carís situation. So here are my OBD codes:

P0550 Power Steering Pressure Sensor Circuit Malfunction
P0605 ECM Fault
P0052 Air Fuel Ratio Sensor 1 Heater Bank 2 Control Circuit High
P0327 Knock Sensor Circuit Low Input Bank 1
P0102 Mass or Volume Air Flow Circuit Low Input
P0113 Intake Air Temperature Sensor Circuit High
P0183 Fuel Tank Temperature Sensor Circuit High Input

Strange thing is that although I have a new TB and MAF sensor, the code is still up for MAF (P0102). Power steering is perfectly fine but there is a code for it. So I have no clue with this.

The dealer said I may need to replace ECM. Knock sensors, o2 sensor and fuel tank temp sensor.

Also they noticed for my ticking sound from the engine, said engine lifter noise is from the right side silicone, need to replace intake manifold gaskets, valve cover gaskets and lifter buckets. However I donít think this is related to other problem.

Yesterday, I towed my car back from the dealership and tried to start up the car. It started without being on a limp mode (but still SES on) so I drove for 30 miles. Car drives normally, no loss of power or anything

Today I start up the car and it is on stall right away, tried again and pressed gas pedal to keep it alive, but the limp mode is on. So I turned off and on again and the limp mode is gone. Drove for 30 second and the limp mode came back, so I parked it and turned it off.

----------weird-------When I turn it on again, the speed and rpm needles were not moving at all but the car started. Background light was on, limp mode lights were gone, but the oil pressure warning light was on with it (WTF?) so I turned it off and on again, the needles were moving normally and the car started without being on a limp mode. I got scared so did not do anything else after this.

And here is my personal questions:
-Is there any possibility that my current situation is related to my previous audio unit problem? (circuit board thing which I replaced)
-A dealer wrote that my carís battery is failed on the capacity test. Is that meaning my battery is done? And might cause this problem? Itís been 2 years since I replaced it. I donít see any signs of short battery yet.
-Maybe bad ECM caused all the problems?

I donít really know what to do now. The car is sitting on my house parking lot and I donít know where to go for real diagnostic and professional repair. So I am desperately asking for any suggestion and possible cause. Thanks for reading such a long post and I am looking for any reply so please help me if you have any idea on my situation. I thank you in advance.
Old 03-08-2013, 02:25 AM
Registered User
iTrader: (3)
Join Date: Mar 2012
location: Toms River, NJ
Posts: 19
Thanks: 0
Thanked 1 Time in 1 Post
Do you smell strong gas odor when you pop the hood. If so it could be related to fuel pump problem or dirty/bad injectors. I understand they said fuel system is good. but did they just look at the Fuel Trim on the scanner thats not gunna tell you . You should pop off the rear seat and do a fuel pressure test ... Someone correct me if I am wrong but it should be 51psi idle. Just remember AIR FUEL SPARK... most everything else is traced to electrical short/sensor

Last edited by CurtyG; 03-08-2013 at 02:31 AM.
Old 03-21-2013, 06:56 AM
Registered User
iTrader: (1)
Join Date: Dec 2010
location: van nuys, ca
Posts: 87
Thanked 6 Times in 5 Posts
to smell strong fuel for this engine would mean leaking injectors. leaking injectors are not common for stock but is common if you have upgraded brands like venom combined with high pressure walbro 255 fuel pump... an injector stuck open will put the car into limp mode as i have had that occur. your symptom seems to be a low voltage or overly high voltage condition. volt meter test the car to see its getting 13.6-14.4v, not less or higher while idling and revving. i've had this issue working on bmw and nissan with faulty alternators.

however, a faulty thermostat with bad o2 sensor also puts a car into limp mode. you mentioned coolant back pressure, this can occur from a blown head gasket, cracked head, or stuck closed thermostat.

replacing throttle body and mass is unnecessary as they both can be cleaned and relearn procedure performed.
The Following User Says Thank You to power2rice For This Useful Post:
Cnkboy (06-18-2013)
Old 04-22-2013, 03:57 PM
Registered User
iTrader: (2)
Join Date: Feb 2013
Posts: 11
Thanked 0 Times in 0 Posts
to find good automotive shops to repair your car as your nearest auto parts store to recommend a shop. Trust me they will know

Related Topics
Thread Thread Starter Forum Replies Last Post
New to the G family, I Need help Terry_G35 New Members Check In 14 08-20-2015 09:56 PM
Throwing P1078 code....which route to take? Muski_G G35 Coupe V35 2003 - 07 10 08-07-2015 08:39 PM
Limp mode CAI G35Sask Intake & Exhaust 16 08-05-2015 10:17 PM
2003 G coupe. Need help guys please Terry_G35 G35 Coupe V35 2003 - 07 8 08-04-2015 02:38 PM
Getting P1128 code - Throttle Control Motor Circuit Short Hasanbaloch Engine, Drivetrain & Forced-Induction 5 07-19-2015 02:13 PM

bad, box, car, climate, control, g35, g37, gas, infiniti, limp, makes, mode, p0605, response, stall, stalled, throttle
Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -4. The time now is 04:21 PM.

Copyright ©2002 - 2017, rupromenergo.ru All Rights Reserved.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Your question will be posted in:

Related pages

heater stopped blowing hot airnissan transmission identificationhankook evo v12 reviewinfinity g35 forumseat belt retainermy car smells like rotten eggsg35 wide body kitinstalling wheel spacerswetsand headlights350z nismo wheelsk&n cold air intake cleaninghow to purge radiatorleather rejuvenator oilevap canister purge volume control valvehow much to fix rack and pinioninfiniti m35 2007 reviewstoptech reviewmost reliable sedansplasti dip san josecustom g35 headlightsmr tire complaintsdls up6m35 customg35x 0 60cost of front struts replacementmy car shakes at 60 mphbmw aerial finp0430infiniti g35 interior partszaino leather careautozone ball jointsplastidip glossyfault code p0340obd code p0340varstoenredline gear oil 75w140magnaflow 14862kenstyle g35stoners trim shinespark plug non fouler to pass emissionsbrake caliper bracket boltjag motors el paso txconverting automatic transmission to manualwheels offset calculatorsaturn ion 2003 batteryhks 350z exhaustg35 coupe rear diffuserdiy helmholtz resonatorwhy does my fuel gauge fluctuatetokico adjustable shockswhat does dtc meanssr type c rimsexhaust meisterschaftengine restore oil additive89 iroc zoakley bucket glasses350z diecastmevotech control armshow to program a viper alarm remotehelix throttle body spacer reviewshalogen h1 bulbp0455 codemb off road rimsprestone asian power steering fluidvertical doors kitcoilover airbags2jz build costinfiniti q50 rimsnnr coilover reviewbc racing coilover spring ratesjennychuwhat causes vibration when braking